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ID Type Description 

461 Requirement Modified the SNMP interface to support customized MIB files. 

467 Requirement 

Created the option to "Read after writing" in the OPC Client 
worksheet. This option is useful to synchronize the values from 
the OPC Server with the values from the OPC Client, especially 
when the same item from the OPC Server can be updated either 
by the OPC Client or by the device (e.g.: PLC) connected to the 
OPC Server. 

469 Requirement 

The driver task was modified to eliminate the limit of 81 
characters when reading/writing string data from/to the device(s). 
This item will only be available for drivers using the new Driver 
Toolkit and that use the Driver Standard to set the string values. 

473 Requirement Created the SNMPSet() built-in function, which allows the user 
to write values to OID addresses, using the SNMP protocol. 

476 Requirement 

Created the SMA (Studio Mobile Access) solution, which allows 
the users to visualize online alarms and tag values from any 
remote device, such as a cell phone, PDA, or regular computer, 
using any web browser capable of displaying HTML pages. 

478 Requirement 

Created a new option on the Help menu, called “Support 
Information”. This option displays information about the local 
system, and about the (remote) target system (if any) connected 
through the Execution Environment interface. The information 
displayed by this option is especially useful when 
requesting technical support. 

500 Requirement 
It was created the option to run the product (runtime) as a 
“Service”, in addition to the existing default mode to run the 
product as a regular “Windows Application”. 

502 Requirement 

Created option to compress files before sending them through the 
Execution Environment to the Remote Agent. Consult the 
product documentation (Execution Environment) for further 
information about how to enable this option. 

464 Change Request Improved the internal structure of the Security System. 

471 Change Request Improved the performance when scanning multiple channels 



along with computed channels from the FlukeDAQ device. 

546 Change Request 
The FileWrite() built-in function was modified to support 
UNICODE format in addition to the already supported ASCII 
format. 

549 Change Request 
Improved the error message displayed when an ActiveX control 
configured on the screen cannot the loaded. The improved 
message describes the possible causes of the error. 

555 Change Request 

Enhanced the development environment to set the startup state of 
the following tasks to "Automatic" (instead of "Manual") when 
creating the first worksheet for each one of them, respectively: 
OPCClient, TCPClient, Database Client, DDE Client, and ODBC 
Client. 

558 Change Request 
Created an option in the "Project Settings --> Runtime Desktop" 
dialog to execute only the command for the topmost object, 
when clicking on objects that overlap. 

565 Change Request 
Improved Import Wizard to configure the OPC Client Task to 
start automatically after creating OPC worksheets and set the 
scope of imported tags to "Server" instead of "Local". 

583 Change Request 

The Text I/O dynamic was modified to display the warning 
message "Invalid entry. Please enter a numeric value." during the 
runtime, when the user attempts to enter a non-numerical value 
for a numeric tag (Boolean, Integer, or Real). 

598 Change Request The default file type supported by the Import Wizard for the 
"TwinCAT PLC Database" was modified from "SYM" to "TPY".

605 Change Request 

The message "Verify Application was completed successfully. 
Check the Output window for a complete log of this 
command" will be displayed after finishing the execution of the 
Verify Application command from the Tools menu. 

606 Change Request 

It was created a warning message to be displayed when saving a 
Trend worksheet, as long as the changes implemented in the 
Trend worksheet will result in incompatibility with the 
proprietary history files created previously by the same 
application. 

608 Change Request 

It was created a new parameter called "SendEveryState" (under 
the section [ISSymbol]) for the <ApplicationName>.APP file. 
When this parameter is set with the value 0 (default), ISSymbol 
(Viewer, Secure Viewer, or Web Thin Client) sends every state 
(tag values) to the Server only for tags that are configured in the 
Driver or OPC Client worksheet, as long as the option "Driver 
and OPC" from "Project --> Settings --> Communication" is set 



to "Send Every State". When this parameter is set with the value 
1, ISSymbol (Viewer, Secure Viewer, or Web Thin Client) sends 
every state (tag values) to the Server for all tags. 

614 Change Request 

There were created additional options for project resolution when 
creating a new project or when converting the resolution of the 
current project. Furthermore, it was created an option where the 
user can customize any resolution (width and height) for the 
project, different from the pre-defined options. 

634 Change Request 
The CEView program was modified to start the application 
faster, especially for applications that have thousands of lines 
configured in the Global Procedures interface. 

636 Change Request 
Created read-only field SendEveryState, which is automatically 
set by the run-time and forces the graphical interface to report all 
the tag changes to the Server Module. 

639 Change Request 

Created an option to configure a custom tag to trigger the MAIN 
DRIVER SHEET read commands. This parameter can be 
configured in the <ApplicationName>.APP, as follows: [Options] 
MainDrvAlwaysTrigger=BlinkSlow 

643 Change Request 

The project (<ApplicationName>.APP file) can be configured to 
download external ActiveX controls and register them 
automatically on the Thin Client station. This algorithm was 
modified to show an error message if, after downloading and 
installing the control, we don't find it in the registry (probably 
because the user specified a wrong CLSID). Also modified to 
download the control using relative path (see Technical 
Reference manual for details) 

652 Change Request Changed the TCP Client task to support IP:PORT in the "Server 
IP Address" field. 

654 Change Request 

The screen editor was modified to resize objects proportionally 
(keeping the ratio between width and height) when using the 
handlers drawn on the corners of the selected object. When 
pressing the SHIFT key, the user is able to resize the object 
changing the ratio between its width and height. 

655 Change Request 
The OPC Client task was modified to improve its reliability and 
report errors, if any, to the Output Window (LogWin) when 
connecting or communicating with third-party OPC Servers. 

657 Change Request 

The TCP/IP Client task was modified to set the quality of the tags 
configured in its worksheets to BAD when the TCP/IP Client 
detects errors when trying to communicate with the remote 
TCP/IP Server. In order to enable the TCP/IP Client task to 
modify the quality of tags, the new parameter 



"SetQualityToBadOnError" from the [TCP] section of the 
<ApplicationName>.APP must be set to 1. 

663 Change Request 

The Linked Symbol was enhanced, allowing the user to group 
Custom Properties in different categories and filter the properties 
per category when editing the objects. The new syntax supported 
by the Linked Symbol is 
"#Category.CustomProperty:DefaultValue", where the 
"Category" and the "DefaultValue" are optional. 

711 Change Request 
CEView was enhanced to support the Picture object, available 
from “Edit --> Past Link”. CEView supports picture files in the 
formats BMP and JPG. 

717 Change Request 

The default setting from "Project --> Setting --> Communication 
--> Driver and OPC" was modified for new applications. The 
new default setting is "Send every state" instead of "Send last 
state". 

780 Change Request The Alarm/Event Control was enhanced to support a third 
optional column when configuring the initial sort. 

794 Change Request 
Changed default for the Virtual Keyboard Show Hint 
configuration in Project->Settings->Runtime Desktop. The 
default is now enabled for new projects. 

839 Change Request 
The graphic interface was enhanced to support background 
pictures for screens with resolution as large as 10000 x 10000 
(pixels). 

877 Change Request 
The built-in SaveAlarmFile() function was enhanced to support 
the Database format, in addition to the Proprietary and Binary 
formats, which were supported previously. 

924 Change Request Increased the size of the "Yes" and "No" buttons in the confirm 
dialog. 

455 Issue 

Modified the algorithm implemented by the 'Replace' feature of 
the 'Object Properties' dialog window, in order to handle properly 
specific syntaxes, such as: Array indexes with expression (e.g.: 
Tag[TagID+1]), and class members and tag fields associated to 
the same custom property (e.g.: #Prop:Class.Member and 
#Prop:Class.Member->Field). 

458 Issue 
Improved the algorithm for the Alarm Deadband Time to make 
sure it works properly, even if the internal clock of the station 
moves backwards. 

462 Issue 
Modified Secure Viewer to display the tag values properly when 
switching to screens after logging with different users more than 
once on the startup screen. 



465 Issue 
Modified Web Thin Client control (ISSymbol) to support the 
"Print Preview" option from the Web Browser (Internet 
Explorer). 

480 Issue 
Modified the DirDelete() built-in function to avoid deleting all 
files from the root directory of the C drive when executing the 
function with no parameters. 

484 Issue 

The algorithm that sorts the addresses in the communication 
driver MAIN DRIVER SHEET was modified to guarantee that 
the addresses are properly organized in virtual communication 
groups. 

486 Issue 

The error messages indicating that VBScript is not supported by 
the device are no longer displayed when the user switches from 
one screen to another. When the device does not support 
VBScript, the error message will be displayed only once when 
running the application. 

541 Issue 

Modified the GetLine() function to return the value of the first 
row of the text file properly when the format of the file is 
UNICODE. The initial UNICODE char (0xFEFF) used to 
indicate the file format is properly ignored by the function. 

542 Issue The graphic interface was modified to support the DayOfYear 
system tag both on the Server and on the Thin Client stations. 

543 Issue 
Modified Execution Environment to support the "Microsoft 
ActiveSync" connection type when linking the development 
environment with devices running Windows Mobile v5.0 or v6.0.

544 Issue The RunVBScript() built-in function was modified to avoid 
memory leaking. 

548 Issue Grid column editor was modified to avoid exceptions. 

550 Issue Modified the product to guarantee that the user is able to add 
shared tags in applications created under Windows Vista. 

554 Issue 
Modified the Trend Control to avoid generating overflow errors 
in VBScripts when a pen configured in the Trend Control has a 
very low value (e.g.: 1e-100). 

562 Issue 

The Trend Task was modified to support String tags. When 
the Trend History Format is set to "Proprietary", the value of the 
String tag is converted to a numeric value before being saved into 
the history file. 

563 Issue The Viewer process was modified to display the value of the 
"Description" tag field properly (e.g.: TagName->Description). 

575 Issue Modified the linked symbols to display property tooltips properly 



even when using grouped properties. 

581 Issue 
The screen editor was modified to keep the relative position 
among the selected objects, even when moving them through the 
borders of the screen. 

596 Issue Fixed the memory leaking issue when generating and displaying 
event messages with more than 64 characters (each). 

597 Issue 
The email notification from the Alarm Task was modified to 
avoid crashing after attempting to send several emails 
unsuccessfully. 

601 Issue 
Modified the Import Wizard for OPC Server Databases 
to support more than 4096 tags from the OPC Server, as long as 
the current license allows it. 

603 Issue 
Removed the "Remote" option from the Import Wizard for 
Studio Database to avoid instability issues on the current 
architecture. 

617 Issue 
The graphic module was modified to guarantee that the values for 
tag fields are properly retrieved, even when using indirect tags 
(@TagName->TagFieldName) to access the tag field value. 

618 Issue 

Modified the Grid object to avoid errors when opening a screen 
with a Grid object (Data Source = Class Tag) where the same 
member of the class tag was configured in more than one column 
of the Grid object. The error would occur only if the Grid object 
was configured in the startup screen. 

623 Issue 

Modified the Viewer task to avoid exception errors when 
defining an expression for custom properties in object dynamics 
(e.g.: #CustomPropertyName:TagName>10). The error occurred 
only when running the application under Windows CE. 

641 Issue 

The development environment was modified to support the built-
in functions StartTask(), EndTask(), and IsTaskRunning() on any 
interface that supports expressions, even if the project is set to 
CEView (Target System). 

648 Issue 
The Smart Message object was modified to display the last 
message configured in the object, even when it is configured to 
blink. 

650 Issue 

The Security System was modified to make sure that Studio is 
able to load the application when the option "Use preferentially 
the Remote Security System" from the Security System is 
enabled, even if the Remote Security System station is not 
available. 



658 Issue 

The driver task was modified to avoid exception errors when 
running projects configured with more than 4095 tags in the 
MAIN DRIVER SHEET. The problem occurred only with 
drivers that did not impose the maximum block size for virtual 
groups from the MAIN DRIVER SHEET. 

659 Issue 

The Driver task was modified to guarantee that the writing 
commands from the MAIN DRIVER SHEET have higher 
priority than the reading commands from the same MAIN 
DRIVER SHEET. 

668 Issue 

The Thin Client control (ISSymbol) was modified to improve the 
performance when switching screens, especially when the 
Primary Server is not available and the Thin Client station is 
connected to the Secondary Server (redundancy). 

674 Issue Improved Import Wizard to configure the Driver Task to start 
automatically after creating driver worksheets. 

698 Issue The Execution Environment was modified to make the Serial 
Port configuration persistent. 

703 Issue 
The Remote Agent for PC (e.g.: Windows XP/Vista/2003 Server) 
was modified to avoid conflicts when trying to run it along with 
the Studio runtime. 

707 Issue 
The settings from the “Project Settings” dialog were updated to 
match the actual default settings for title bar, menu, and status 
bar. 

708 Issue 
The device driver for the USB Hardkey was updated to solve 
incompatibility issues with 64-bits operating systems, such as 
Windows Vista 64-bits or Windows 2008 64-bits. 

716 Issue The PrintWindow() built-in function was modified to run 
properly under Windows CE. 

739 Issue 
The Studio ADO Gateway (StADOSvr.exe) was modified to 
support timestamp with milliseconds precision for the history 
tasks: Alarm, Event, and Trend. 

740 Issue Resolved problem with daylight savings when running the Fluke 
DAQ devices. 

752 Issue 
Modified algorithm for Print Preview to prevent problems when 
using the system close button (upper right x) to close the Print 
Preview window. 

758 Issue 
Modified VBScript compilation to properly handle pointers to 
integers. The current algorithm was causing the assignment 
@MyIntegerPointer=1 to be handled as 



@MyIntegerPointer=True and as a result the integer tag being 
pointed to would receive -1. 

759 Issue 
The following tag fields were modified to assume the value 1 
when writing any value different from 0 to them: “Ack”, 
“AlrDisable”,  and “Unack”. 

760 Issue The hardkey interface was updated to support the Sentinel USB 
Hardkey under Windows XE Embedded (WinXPe). 

764 Issue 

Fixed problem with Trend Control when saving the Min/Max 
values for pens that have not been added to the trend run-time. 
The trend was saving the Min/Max as 0 for these pens and if the 
user inserted them after loading the configuration (which happens 
when you close and open a trend screen) the pen would be 
inserted with Min/Max of 0. 

767 Issue 

The behavior of the State field used to filter messages from the 
Alarm/Event Control object was modified to support the 
following options: 0: No filter (all states) 1: Active and not 
acknowledged 2: Active and acknowledged 3: Normalized and 
acknowledged 4: Normalized and not acknowledged 

771 Issue 
The Import Wizard for the “TwinCAT PLC database” was 
modified to avoid setting the type of String tags imported from 
the TPY file as Real tags. 

777 Issue 
The behavior of the screen dynamics was modified to avoid 
triggering command dynamic when the object is updated by other 
dynamics. 

786 Issue 
Modified the option "Import Strings" in the translation tool to 
include the header texts from objects that support column header 
(Alarm, Trend Legend and Grid). 

796 Issue Modified the built-in function Hst2Txt() to prevent exceptions 
when invalid parameters are specified. 

799 Issue Fixed problem with functions DateTime2Clock, ClockGetDate 
and ClockGetTime when running on Windows Vista. 

800 Issue 
Modified the screen editor to avoid asking if the user wants to 
save screens with the Trend object, even if the user did not 
implemented changes on it. 

804 Issue 

Modified the development environment not to reset tag values 
when the run-time is running and the same application is loaded 
in the development environment by using the command 
"RunStudio AppName" or by double clicking in the application 
file. 



813 Issue Improved the performance of TWCAT import wizard and 
implemented algorithm to ignore pointers when importing. 

860 Issue 
Modified the built-in Virtual Keyboards to display the correct 
ASCII character when pressing the space bar on the Virtual 
Keyboard. 

861 Issue 
Trend control was modified to resolve problem with break 
interval when the break happens between the first two samples 
and then to consecutive samples. 

879 Issue 

The graphic module for Windows CE was modified to avoid 
displaying "#" characters instead of actual values. The problem 
would occur when configuring specific expressions with Custom 
Properties. 

892 Issue 
Fixed problem with Pocket PC that would generate exceptions 
when switching between screens in some specific Windows CE 
devices. 

893 Issue The device driver for the USB Hardkey (beige) was updated to 
avoid memory leaking that could result in a system crash. 

895 Issue Modified hardkey license interface to address compatibility 
issues with Windows 2008. 

908 Issue Modified the Viewer module not to reload screens when tags 
with retentive parameters have their parameter values changed. 

911 Issue Modified Linked Symbols capability to support combo boxes 
even on HMIs with ARMV4I processors. 

913 Issue 
Fixed problem with Text I/O when used on Screens with Hide 
option enabled. The hide would cause the Text I/O to be loaded 
only in the first time that you open the screen. 

 

InduSoft Web Studio v6.1 + Service Pack 5 ‐ Known Issues 
(Friday, January 16, 2009) 

ID Type Description 

604 Issue 

The column to delete alarm messages from the Alarm/Event 
object, when configured as the first column, is displayed too 
small on Windows Vista. [WORKAROUND]: Configure any 
other field as the first column. 

626 Issue Remote on-line screen update does not work when downloading 



large screen files to specific devices. [WORKAROUND]: Stop 
the application and execute the "Send Application" command. 

664 Issue 
The "Task Switch Enabled" from the Security System Groups is 
not working on 64-Bits operating System. [WORKAROUND]: 
Use a third-party package to block the keyboard actions. 

712 Issue 
Studio is unable to print to PDF on Windows 64-Bits and on few 
specific Windows XP Embedded devices. [WORKAROUND]: 
Install a third-party PDF Printer and set it as the default printer. 

715 Issue 

The Web Tunneling Gateway is not installed automatically on 
Windows 64-Bits. [WORKAROUND]: Install the Web 
Tunneling Gateway manually, executing the WebGtw.exe 
program from the \BIN sub-folder of Studio. 

757 Issue 

The Message Box from VBScript is displayed behind the screen 
when called from a background script.[WORKAROUND]: Call 
the Message Box from the Graphic Script, based on the condition 
triggered by the background script. 

836 Issue 

Studio generates unpredictable errors when a built-in function 
name is placed within parenthesis. [WORKAROUND]: Avoid 
entering with statements such as (FunctionName) in studio 
expressions. 

873 Issue 

When the user has only one pen in the trend and the Min/Max is 
not specified, the trend uses the point color to show the label 
instead of using the Y Axis font color. [WORKAROUND]: Add 
a second pen to the Trend Control and make the second pen 
invisible. 

884 Issue 

Thin Client stations take a long time to load some screens for the 
first time. [WORKAROUND]: Configure objects on the screen 
with the tags used in the screen script. For example, transparent 
rectangle with tags in the Caption. 

894 Issue 
Evaluation mode does not work on Windows VISTA. 
[WORKAROUND]: Run the development environment at least 
once as Administrator (right-click > Run as Administrator). 

917 Issue 

Option "Time Before Now" in the trend control only handles 
Integer numbers in the "Time" field . [WORKAROUND]: Use 
the option "Start Time" and set both the duration and the start 
time tags in order to change the trend timeframe. 

928 Issue 

New Applications on Windows Vista are not being created 
properly. [WORKAROUND]: When createing the new 
application, point to the <Operating System> <USER> folder 
instead of subfolders from Program Files, Windows, or Root 



Folders 

931 Issue 
Trend Control does not automatically move to the daylight saving 
time when running in online mode and on some specific WinCE 
devices. [WORKAROUND]: Reload the trend screen. 

932 Issue 
On very rare cases, changing a linked symbol causes custom 
default property values to be lost [WORKAROUND]: Reinsert 
the linked symbol to restore the default values. 

933 Issue 

On computers with limited temporary storage Secure Viewer 
sometimes displays background images different from the ones 
created for the screen. [WORKAROUND]: Remove the user 
temporary files to allow enough space for Secure Viewer 
temporary files. 

934 Issue 

On some specific hardware the external LogWin causes Studio to 
close when logging to disk. [WORKAROUND]: Log to a file 
that has already been created, after the problem has happened for 
the first time the file is created, so simply restart. 

 


